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Session 1. Getting Started

Summary

This session introduces the purposes and scope for this e-book, emphasising the importance of students in geography, environmental science and related disciplines having a reasonable knowledge of statistics and of quantitative approaches for research, and for social and scientific debate. It sets out what needs to be installed to work through this book and provides an initial introduction to the computing, statistical and graphical environment, R.

In this session you will

· Learn about these sessions and why they were written.

· Learn how to install R, install packages and to load libraries.

· Learn the basics of how to manipulate data in R.

About this e-book

This e-book is offered as a learning resource to accompany the textbook 'Statistics for Geography and Environmental Science' by Richard Harris and Claire Jarvis (Prentice Hall, 2011). Its specific focus is to consider some of the statistical methods and techniques presented in that book and show how they are undertaken in the statistical computing software called R. It will be of interest to teachers and to students who are using R for the first time and want a simple introduction to it.

This book does not pretend to be a comprehensive introduction to either statistics or to R. On the statistical side, it is designed to be read with the parent textbook, to which cross-references are made, offering directed reading and guided learning. A recommended text for R is the Introduction to R which comes with the software and also is available at http://cran.r-project.org/manuals.html. For a more detailed exposition see 'R in a Nutshell' by Joseph Adler (O'Reilly, 2010). For a  detailed treatment of statistics in R see 'Data Analysis and Graphics using R' by John Maindonald and John Braun (2nd edition, Cambridge University Press, 2007) or 'Statistics: an Introduction using R' by Michael Crawley (Wiley, 2005).

Why statistics?

Learning at least a little about statistics is an essential task for anyone in geography and related disciplines. The links with science are obvious but it also is essential for learners who find affinity with the social sciences and the humanities. The simple fact is that data and numbers are used widely in all areas of research, public policy, business and commerce, and to provide information that is said to help us make good choices as well-informed consumers. The danger is that without at least some knowledge of how statistics are used and why, we are in no position to scrutinise a statistic and to differentiate credible uses from nonsense.

Consider the following example (from http://www.social-statistics.org/?p=322) which reflects on a table published in the UK Government's White Paper on Universities, Students at the Heart of the System (2011). That table (section 1.17) compares monthly repayments under the existing and proposed systems of course fee repayments. It shows that under the new system graduates earning £21k per year will pay back nothing, compared to the £45 under the current system. Graduates earning £24k will pay back £22.50 compared to the current £67.50. Those earning £27k pay £45 and £90, respectively. And so forth. The take-home message is that the new system is progressive.

This is a good example of why it is important to think through what the numbers are actually presenting. Specifically, these are repayments on a debt - a debt that will nearly tripled compared to the current system. The less you pay back, the more interest you accrue, and the more you pay back in the long term. There may be an argument for saying the debt repayments are more manageable under the new system but it can't be ignored that graduates are going to be paying a lot more overall. Furthermore, those on lower incomes who are unable to pay off their debt for many years will end up paying much more than those who get well-paid jobs and make a quick repayment. That’s an unusual definition of “progressive”!

Nevertheless, it is important to not  just be cynical about statistics. It's not true that they can be used to prove anything. Yes, they can be misused, but so can any form of language and (mis-) communication. However, they are also used to provide important and credible evidence for things that are happening (or not), whether that be a rise in unemployment, a reduction in crime, the pollution of a watershed or an outbreak of an infectious disease. Studying statistics encourages an approach to research that is reflective, thoughtful and mindful of the limitations of data and their analysis. Encouraging the researcher to form a clear and manageable research question, a means to answer the question, and awareness of the assumptions, methodological limitations and the researcher's own prejudices are qualities conducive to all empirical work, quantitative or qualitative.

About R

R is a free software environment for statistical computing and graphics. It is available for Mac, Windows and Linux Operating Systems (of which the first two will be concentrated on here). Although graphical user interfaces have and are being developed for R, most uses of R will be in a command-line form where the user types the commands they want R to execute and doesn't use drop-down menus, tabs or other point-and-click methods. This makes R both faster to use and much more customisable. It allows scripts to be written in simple text editors and then cut and pasted into R to run. Graphics can be easily modified and tweaked by making slight changes to the script or by scrolling through past commands and making quick edits.

Unfortunately command-line computing can also be off-putting at first. It is easy to make mistakes that aren't always obvious to detect. Nevertheless, there are good reasons to stick with R. These include:

· It's broadly intuitive with a strong focus on publishable-quality graphics.

· It’s ‘intelligent’ and offers in-built good practice – it tends to stick to statistical conventions and present data in sensible ways.

· It’s free, cross-platform, customisable and extendable with a whole swathe of libraries ('add ons') including those for mapping, spatial statistics, spatial regression and geostatistics.

· It has a large and and helpful user community. R-help and other mailing lists can be accessed from http://www.r-project.org/mail.html.

· It is well respected. Look what Adler (2010, p. xv) writes: “R is used at the world’s largest technology companies (including Google, Microsoft and Facebook), the largest pharmaceutical companies (including Johnson & Johnson, Merck, and Pfizer), and at hundreds of other companies. It’s used in statistics classes at universities around the world and by statistical researchers to try new techniques and algorithms.”

· It offers a transferable skill that shows to potential employers experience both of statistics and of computing.

Obtaining and installing R

R is downloaded from the Comprehensive R Archive Network (CRAN) at http://cran.r-project.org/. Windows users will want to select, download and double click on the “base” distribution (e.g. R-2.13.1-win.exe) to install R. As the name suggests, this installs R's base libraries and functionality. A shortcut to R will be placed on your desktop that you can use to launch the R Console.  This will bring up a window into which R commands can be entered. It also has some drop-down menus that can be used to change the working directory (the default location for saving files), for opening or closing workspaces (saved collections of R objects: see below), and so forth.

The R Consoles are not identical for different operating systems but all the commands used here (and most others) are.

Getting Started

Before proceeding you'll need to:

(1) Make sure you have access to or have downloaded and installed R.

(2) Install the R package SGES which provides the data and some of the functions used here.

(3) Install the other packages upon which SGES is dependent

(4) Load the SGES library.

To (1) download the SGES package:

(b) Go to http://www.social-statistics.org/?page_id=354
(c) Download SGES.zip (Windows) or SGES.tar.gz (Mac)

To (2) install the other packages on which SGES depends:

(b) Launch R. Inside the R Console you will find text similar to the following


R version 2.13.1 (2011-07-08)

Copyright (C) 2011 The R Foundation for Statistical Computing

ISBN 3-900051-07-0

Platform: i386-apple-darwin9.8.0/i386 (32-bit)


R is free software and comes with ABSOLUTELY NO WARRANTY.

You are welcome to redistribute it under certain conditions.

Type 'license()' or 'licence()' for distribution details.


Natural language support but running in an English locale

R is a collaborative project with many contributors.

Type 'contributors()' for more information and

'citation()' on how to cite R or R packages in publications.


Type 'demo()' for some demos, 'help()' for on-line help, or

'help.start()' for an HTML browser interface to help.

Type 'q()' to quit R.

(b) Make sure you have an Internet connection and read-write access to the drive on which R is installed. If you don't, you will need to ask your systems administrator to install the package for you.

(c) Within the R console (and after the prompt > ) type,

install.packages(c("spdep","RColorBrewer","lmtest","HH",))

(and press return).

To (3) install the SGES package:

(d) Windows users: From the drop-down menus choose Packages → Install Packages from local zip files and navigate to the SGES.zip file downloaded earlier. Installing the library requires you have read-write access to the drive (by default c:) on which R is installed. If you don't, you will need to ask your systems administrator to install the package for you. Or, you could install and run R from a USB stick instead.


Mac users: From the drop menus choose Packages & Data → Package Installer. Change 
from CRAN (binaries) to Local Source Package, press Install and navigate to the file 
SGES.tar.gz.

Finally, (4) to load the SGES package,

(a) within  the R console (and after the prompt >)  type library(SGES) (and press return). Nothing obvious necessarily will happen.

(b) If you wish, you can check that it has loaded by typing (.packages()) exactly as written (and press return). You should find SGES listed amongst them.

TIP: You will need to load the library each time you use R in conjunction with this workbook. You only need to install it once.

A first look at R

We will now get an initial feel for R. Don't worry if not everything makes sense at this stage and don't try and memorise the commands. The purpose here is to learn by doing, not to make you an instant expert in R.

With the R Console open and the SGES library loaded (see above) type load(rabies). Here, and from now on, press return after each portion of code without further prompting.

The command loads into the workspace a table of data that came bundled with the SGES library. The data give the number of reported cases of human rabies in the United States for each of the years 1974-2005 (see Table 2.1 in Statistics for Geography and Environmental Science). The source of the data is the Centers for Disease Control and Prevention.

The workspace is a collection of objects in R. Type ls() to list the current objects in your workspace. The object rabies should be among them.

To view the data, simply type rabies and the contents of the object will be displayed on-screen. For very long datasets it is better not to output all the data to the screen. It can be useful to check the top and bottom of the data instead:

head(rabies)

tail(rabies)

To view the data as a chart, type plot(rabies).  To join the dots together, type

plot(rabies, type="l")

(the l is short for line). Compare the result with what happens when you type

plot(rabies, type="b", ylab="Number of cases", main="Cases of human rabies, 1974-2005")

(the b is short for both)

TIP: The spaces between the words don't matter but the positions of the commas and brackets do. If you find the prompt, >, is replaced with a + it is because the command is incomplete. If necessary, hit the escape (esc) key and try again. 

Now add some additional annotation to the graph by typing

abline(h=mean(rabies$cases), col="dark red", lty="dotted")

(adds a dark red and dotted horizontal line crossing the vertical axis at the average number of rabies cases for the period).

And

legend("topleft", legend="Mean average", lty="dotted", col="dark red")

(adds a legend)

The result should be as below and is your first chart in R.

Figure 1.1. A first graph in R, showing the number of reported cases of human rabies in the United States, 1974-2005 (Data source: Centers for Disease Control and Prevention, 2007).[image: image2.png]Number of cases.
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TIP: You can cut and paste the graphic into other documents such as a word processor.

Explanation

When you type the command plot(rabies) you are running a function called plot and passing to that function the object in the workspace called rabies. R has recognised rabies as an object of class type data.frame and with two dimensions that can be plotted as above. A data frame is the type of object generally used to store a table of data in R. You can confirm it is of this type by typing class(rabies).

The appearance of the plot is changed by altering the arguments of the function. For example, the argument ylab is used to change the label given to the vertical, y-axis and main gives the chart a title. There are other arguments that can be changed too. These are listed, with examples of their use, by typing either ?plot or help(plot). Similarly, to learn more about the abline function, type ?abline or help(abline).

Viewing and manipulating parts of the data

We will view again the top of the rabies data but this time show the first 10 rows of the data instead of the default of six,

library(SGES)

# This is a comment, you don't need to type it! 

data(rabies)

# You only need to type the library and data




# commands if you've closed and reopened R

head(rabies, n = 10)

We can see that the data have two variables, named year and cases. Confirm this by typing,

names(rabies)

Imagine we wanted to change the name of the second variable to incidents. To do so, use

names(rabies)[2] = "incidents"

By again typing names(rabies) find that the variable name has been changed.

TIP: Use the ↑ and ↓ keys to scroll up and down through past commands and edit or rerun them.

Viewing rows of the data

Another way of viewing the first 10 rows of data is

rabies[1:10, ]

# 1:10 means 1 to 10

The first row of data, the second row, and the first and second rows of data (together) may be viewed using

rabies[1, ]

# The first row

rabies[2, ]

# The second row

rabies[1:2, ]

# The first and second rows

rabies[c(1,2), ]
# Another way of showing the first two rows.




# You can read the c(...) function as combine

Viewing columns of the data

There are various ways to view a specific variable, a column in the data table. The following are equivalent

rabies[ ,2]

rabies[ ,"incidents"]

rabies$incidents

To view, for example, the values of the incidents variable for the first 10 rows of the data, use any of the following

rabies[1:10,2]

# i.e. Select rows 1 to 10 from column 2

rabies[1:10,"incidents"]

rabies$incidents[1:10]

Creating subsets of the data

Imagine we wanted to examine the number of cases of human rabies for the period 1980 to 1989. To do so we will search the data and ask whether the year is within that range. The answer will be either TRUE (it is) or FALSE (it isn't).  We will then look at the incidents variable for those rows of the data where it is true, extract the data for those rows and store them in a new object called eighties.cases.

in.range = rabies$year >= 1980 & rabies$year <= 1989

# A logical statement: the year is between 1980 and 1989 (TRUE or FALSE)

# in.range is just an arbitrary object name

head(in.range)

eighties.cases = rabies$incidents[in.range]

# Again, eighties.cases is just a name.

head(eighties.cases)

plot(eighties.cases, type="b")

Calculating a proportion and a percentage

In 1975 there were two incidents of human rabies. 1975 is the second row of the data so we could use rabies[2,] to check this is correct. Alternatively, we could search through the data to find the row where the year is 1975:

rabies[rabies$year == 1975,]

Or determine the row by using

which(rabies$year == 1975)

To calculate the proportion of the total cases per year we need to know the total number of cases:

rabies.total = sum(rabies$incidents)

rabies.total

The proportion is calculated by dividing the number of incidents per year by the total

rabies$incidents / rabies.total

The value for 1975 is

(rabies$incidents / rabies.total) [2]

Which, as a percentage, is

(rabies$incidents / rabies.total * 100) [2]

And rounded to two decimal places

round((rabies$incidents / rabies.total * 100), 2) [2]

The results could be stored in a new object

percentage.cases =
round((rabies$incidents / rabies.total * 100), 2)

percentage.cases[2]

plot(rabies$year, percentage.cases, type="b")

Saving the workspace and exiting R

It is important to save the workspace regularly. This saves all the objects you've created or modified during your R session. A simple way to save it to use either the drop-down menus or

save.image(file.choose(new=T))

Give the file a name like session1.RData (type the .RData part, don't assume it will be added automatically).

To load a previously saved workspace, use

load(file.choose( ))

You can also use File → Save Workspace and File → Load Workspace in Windows, or Workspace → Save Workspace File and File → Load Workspace File in the Mac version.

In addition, you can save the screen text input and output (but not the graphics) to a text file by using File → Save History in Windows, or File → Save in the Mac version. Note that this does not save the workspace, just the screen input and output.

To exit R, use quit(). On doing-so, you will be asked whether you want to save your workspace image. If you select yes it will be saved as the file .RData in the default working directory, which you can determine by typing getwd() before you quit. On rerunning R, the workspace will be restored automatically to how you left it. This can be useful but may also mean that you keep running R with objects that you no longer need. To tidy-up the workspace you can delete specific objects before quitting. For example,

rm(eighties.cases)

Or, if we had created a number of objects – seventies.cases, eighties.cases, nineties.cases, for example – then they could all be removed using

rm(seventies.cases, eighties.cases, nineties.cases)

(if you try it now it will generate an error messages because we didn't create two of those objects and the other been deleted already). 

Finally, you can delete everything in your workspace by using

rm(list=ls())

Be careful, though. There is no undo function.

Other ways of reading data into R

The data() function works because the rabies data are bundled with the library SGES.

A simple way to read other data into R is to use the read.table() function that you can learn more about by accessing its help file, ?read.table.

Particularly useful are its variants read.csv() and read.delim() that are used for reading files containing comma separated variables (.csv) and tab delimited, respectively.

A good way of getting data from a spreadsheet software into R is

(1) Open the data in the spreadsheet. Also clean and tidy it there (getting rid of any superfluous rows of data, columns, etc.). It is much easier to do the cleaning now than in R.

(2) Save the data in .csv format.

(3) Use a command of the form mydata = read.csv(file.choose(), header=T) to read the data into a data.frame called mydata in R, assuming that the top row of the data is a header containing the name of each variable. If there is no header, use mydata = read.csv(file.choose(), header=F).

For further information, see the R Data Import/Export manual at http://cran.r-project.org/manuals.html.

Directed reading

Read Chapter 1 of the textbook Statistics for Geography and Environmental Science to:

· Appreciate the importance of studying statistics as a student of geography, environmental or geographical information science.

· Define and consider more specifically geographical data and analysis.

· Learn about some of the debates and misunderstandings surrounding the use of numbers and statistics in human and social geography.
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